
Example:  Companies.jmp (Help > Sample Data) 

Bar Charts and Frequency Distributions 

Use to display the distribution of categorical (nominal or ordinal) variables.  For the continuous (numeric) 

variables, see the page Histograms, Descriptive Stats and Stem and Leaf. 

Bar Charts and Frequency Distributions 

1. From an open JMP data table, select Analyze > Distribution. 

2. Click on one or more nominal or ordinal variables from Select 

Columns, and click Y, Columns (nominal variables have red bars, and 

ordinal variables have green bars). 

3. If you have summarized data (a column with counts), enter the 

column into Freq. 

4. Click OK to generate bar charts and frequency distributions for each 

variable.  

Tips: 

 To change the display from vertical to horizontal, click on the top red 

triangle and select Stack. 

 To change future output to horizontal, go to Preferences > Platforms 

> Distribution, click Stack and Horizontal, then click OK. 

 To change the graphical display for a variable, or to select additional 

options, click on the red triangle for that variable. 

 Click on bars in one graph to see the distribution the variable across other variables (dynamic linking). 

 Categorical variables display in alphanumeric order.  To change the display order, use the Value Ordering or 

Row Order Levels column property (right-click on the column, select Column Info, then Column Properties).  

Bar Charts – Another Way 

1. Select Graph > Graph Builder. 

2. Click, then drag and drop a nominal variable from Select 

Columns to the X zone on the bottom of the graph. 

3. Click on the bar chart icon above the graph. 

4. Drag and drop a continuous weight variable from Select 

Columns to the Y zone on the left of the graph, or a drag 

and drop a count or frequency variable to the Freq field. 

5. Select a statistic to be plotted from list of Summary 

Statistics (bottom left). 

6. When finished, click Done (top left) to close the control 

panel. 

 
Notes:  Bar charts can also be created in the Chart platform 
(Graph > Chart).  For more details on creating bar charts, see 
the book Basic Analysis and Graphing (under Help > Books).  
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Example: Failuresize.jmp (Help > Sample Data) 

Pareto Plots and Pie Charts 

Use to display the distribution of categorical (nominal or ordinal) variables. Pareto plots sort in descending order 

of frequency of occurrence or weight (value).   

Pareto Plots 

1. Select Analyze > Quality and Process > Pareto Plot. 

2. Click on a nominal variable from Select Columns, and 

click Y, Cause (nominal variables have red bars, ordinal 

variables have green bars). 

3. If you have summarized data, enter the Count column 

into Freq.  

4. Click OK to generate the Pareto plot .  

Tips:  

 To change the display or select 

additional options, click on the red 

triangle. 

 To change the display from a Pareto 

plot to a pie chart, click on the red 

triangle and select Pie Chart. 

 To label a bar or slice of the pie, right-

click on the category and select 

Causes > Label. 

Pie Charts – Another Way 

1. Select Graph > Chart. 

2. Click on a nominal variable from Select Columns, and click 

Categories, X, Levels. 

3. If you have summarized data, click on the blue triangle next 

to Additional Roles, and enter the Count column into Freq. 

4. Under Options, click on the small black triangle next to Bar 

Chart and select Pie Chart. 

5. Click OK to generate the pie chart.  

6. To change the display from a pie chart to a bar chart, click 
on the red triangle and select Pie Chart. 

 
 
Notes: Bar charts can also be produced from Analyze > Distribution or Graph > Graph Builder. For more details 
on creating pie charts and Pareto plots, see the books Basic Analysis and Graphing and Quality and Reliability 
Methods (under Help > Books). 
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Example: Car Poll.jmp (Help > Sample Data) 

Mosaic Plot and Contingency Table  

Use to examine the relationship between two categorical variables. A contingency table shows the frequency 

distribution of the variables in a matrix format, while a mosaic plot graphically displays the information.   

The Contingency Table Analysis  

1. Select Analyze > Fit Y by X.  

2. Click on a categorical variable from Select Columns, and click Y, 

Response (categorical variables have red or green bars). 

3. Click on another categorical variable and click X, Factor.  

4. Click OK. The Contingency Analysis output will display. 

Mosaic Plot 

The mosaic plot is a side-by-side divided bar chart that allows you to 
visually compare proportions of levels of one variable across the 
levels of a second variable. 
 
 
   

 

 

 

Contingency Table 

The body of the contingency table displays:  

 Count – the cell frequencies (counts). 

 Total % - the cell’s percentage of the total count. 

 Col % - the cell’s percentage of the count for the column. The 
column variable is the Y variable, type. 

 Row % - the cell’s percentage of the count for the row. The row 
variable is the X variable, marital status. 

 
The borders of the contingency table display the column totals (across the 
bottom), row totals (on the right), and the grand total (lower right corner). 
 
Tips: 

 Click on the red triangle next to Contingency Table to select or deselect display options. 

 Right-click on the mosaic plot to change colors (Set Colors) or label cells (Cell Labeling). 

Note: See the Basic Analysis and Graphing book (under Help > Books) for more details.   
 

Interpretation: 

1. The widths of horizontal bars represent the proportions of the levels 
of the X variable (in this example, marital status).  

2. The heights of vertical bars on the far right represent the 
proportions of the levels of the Y variable (type). 

3. The cells in the plot represent the proportions for every 
combination of category levels. In this example, Married and Family 
is the largest overall proportion. 

X = Married 
Y = Family 

Legend 
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Example: Car Physical Data.jmp (Help > Sample Data) 

Histograms, Descriptive Statistics, and Stem and Leaf 

Use to display and describe the distribution of continuous (numeric) variables. Histograms and stem and leaf 

plots allow you to quickly assess the shape, centering and spread of a distribution. For categorical (nominal or 

ordinal) variables, see the page Bar Charts and Frequency Distributions. 

Histograms and Descriptive Statistics 

1. From an open JMP® data table, select Analyze > Distribution. 

2. Click on one or more continuous variables from Select Columns, and click Y, Columns (continuous variables 

have blue triangles). 

3. Click OK to generate a histogram, outlier box plot and descriptive statistics. 

 The percentiles, including quartiles and the median, are listed under Quantiles. 

 The sample mean, standard deviation and other statistics are listed under Summary Statistics. 

 

Tips:   

 To change the display from vertical to horizontal (as shown), click on the top red triangle and select Stack. 

 To change the graphical display for a variable, or to select additional options, click on the red triangle for 

that variable. 

 To display different summary statistics, use the red triangle next to Summary Statistics.  

 To change all future output to horizontal, go to Preferences > Platforms > Distribution, click Stack and 

Horizontal, then click OK. 

Stem and Leaf Plot 

To generate a stem and leaf plot, click on the red triangle 

for the variable and select Stem and Leaf.  

Tips: 

 A key to interpret the values is at the bottom of the plot. The top value in this example is 4300, the bottom 

value is 1700 (values have been rounded to the nearest 100). 

 Click on values in the stem and leaf plot to select observations in both the histogram and the data table. Or, 

select bars in the histogram to select values in the stem and leaf plot and data table. 

Note: For more information, see the book Basic Analysis and Graphing (under Help > Books). 
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Quantile 

Box Plot 

Outlier 

Box Plot 

Example: Companies.jmp 

(Help > Sample Data) 

Box Plots 

Use to display the distribution of continuous variables. They are also useful for comparing distributions. 

Box Plots – One Variable 

1. From an open JMP® data table, select Analyze > Distribution. 

2. Click on one or more continuous variables from Select Columns, and Click Y, 

Columns (continuous variables have blue triangles). 

3. Click OK. An outlier box plot is displayed by default next to the histogram (or 

above if horizontal layout). To display a quantile box plot, select the option from 

the red triangle for the variable. 

 

 

 

 

 

Box Plots – Two Variables 

1. Select Analyze > Fit Y by X. 

2. Click on a continuous variable from Select Columns, and Click Y, Response. 

3. Click on a categorical variable and click X, Factor (categorical variables have red or green bars). 

4. Click OK. The Oneway Analysis output window will display. 

5. Click on the red triangle, and select Display Options > Box Plots to display quantile box plots, or select 

Quantiles to display both box plots and quantiles (shown right).   

 

 

 

 

 

 

Notes: Box plots for one or more variables can also be generated from Graph > Graph Builder. For more 

information on box plots, see the book Basic Analysis and Graphing (under Help > Books). 

The lines on the 

Quantile Box Plot 

correspond to 

the quantiles in 

the distribution 

output. 

The Outlier Box Plot shows the box, plus: 

 IQR = the 3
rd

 quartile minus the 1
st

 

quartile. 

 Whiskers drawn to the furthest point 

within 1.5 x IQR from the box. 

 Potential outliers (disconnected 

points). 

 A red bracket defining the shortest 

half of the data (the densest region). 
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Example: Car Physical Data.jmp (under Help > Sample Data) 

Scatterplots 

Use to display the relationship between two continuous variables. Continuous variables have blue triangles. 

Scatterplots – Two Variables 

1. From an open JMP® data table, select Analyze > Fit Y by X. 

2. Click on a continuous response (or dependent) variable in Select Columns, and Click Y, Columns.  

3. Click on a continuous predictor (or independent) variable, and click X, Factor. 

4. Click OK to generate a scatterplot.  

 

Scatterplots – More than Two Variables 

1. Select Graph > Scatterplot Matrix.  

2. Select all continuous responses of interest, and click Y, 

Columns. 

3. Click OK to generate the scatterplot matrix. 

 

 

 

Notes: Scatterplots and scatterplot matrices can also be generated from Analyze > Multivariate Methods > 

Multivariate and from Graph > Graph Builder.  For more information, see the book Basic Analysis and Graphing 

(under Help > Books). 

jmp.com/learn     rev 07/2012 



Example: GNP.jmp (under Help > Sample Data) 

Run Charts (Line Graphs) 

Use to display continuous data in time sequence.   

Run Charts (Overlay Plot) 

1. Select Graph > Overlay Plot. 

2. Select one or more continuous variables from Select Columns and click Y. 

3. If you have a column that indicates time ordering, enter the column into X, and click OK. 

4. Click on the red triangle and select Y Options > Connect Points to draw a line through the points, and Y 

Options > Show Points to hide the points. 

5. Right-click on the graph to change graph properties (select Line Width Scale to change the line thickness).  

 

Run Charts – Another Way (Graph Builder) 

1. From an open JMP® data table, select Graph > Graph 

Builder. 

2. Drag a variable (or multiple variables at once) from the 

Variables list and drop in the Y zone.   

3. Drag and drop a variable indicating the time ordering in 

the X zone. 

4. Click on the Line icon in the graph pallet (top middle). 

5. Click Done, and fine tune as desired (see tips below). 

Tips:  

 Right-click on the graph and select Graph to change the line thickness or other graph properties. 

 Click on the graph title or axis labels to change, or double-click on an axis to change the scaling. 

 Click on the red triangle next to Graph Builder to re-open the control panel, hide the legend, and more. 

 

Notes: Run charts can also be produced from the Control Chart platform (Analyze > Quality and Process > 

Control Chart > Run Chart). For more information on creating line graphs or run charts, see the books Basic 

Analysis and Graphing and Quality and Reliability Methods (under Help > Books). 
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Example: Big Class.jmp (under Help > Sample Data) 

Interactive Graphing with Graph Builder 

Use Graph Builder to interactively create graphs for one or more variables, including line plots, splines, box 

plots, bar charts, histograms, mosaic plots, maps and more.   

Drag and Drop to Visualize Data 

1. From an open JMP® data table select Graph > Graph 

Builder.  

2. Drag a variable from the Variables list and drop it in the 

desired drop zone. In the examples (right), Weight is in the Y 

zone and Height is in the X zone.  

3. To add a grouping variable, drag and drop a variable in the 

Group X or Group Y zone. In the example, Sex is in the 

Group X zone. 

4. To change the graphical display, click on a graph element 

icon. Or, click and drag an icon onto a graph frame. Here, 

Line of Fit has been selected. 

5. Change Summary Statistics and other display options for 

the selected graph elements. 

6. Click the Done button (top left) when finished. 

Tips:  

 Right-click in the graph to change graph properties.   

 To replace a variable with a new variable, drag the new 

variable and drop it in the center of the drop zone. 

 By default, Graph Builder displays data points. If continuous variables are in both the X and Y zones a smooth 
spline will display (lambda = 0.05). 

 More than one variable can be assigned to an X or Y zone, or to a group zone. Drag a 

variable to either side of the existing variable in the zone – a blue ribbon will indicate 

where the new variable will be placed when dropped. 

 To change the modeling type (to use different graph elements), right-

click on the variable and select the new data type (if available). 

 

Other Drop Zones:  

 Drop a variable in Wrap to trellis the graph horizontally and vertically.   

 Drop a variable in Color to create a legend and color by values of the variable. 

 Drop a variable in Overlay to color and overlay graphs for each value of the variable on one graph. 

 If data has been summarized (a frequency variable exists), drag the variable to the Freq zone. 

 If a column defines a physical shape, drag the variable to Shape to create a map (shape files must exist).  

 Drop a variable in Size to scale markers or map shapes according to the value of the size variable. 

 
Note: Instructions also apply to the iPad® Graph Builder Application (see jmp.com/iPad). For more details on 
creating interactive graphics with the Graph Builder, see the book Basic Analysis and Graphing (under Help > 
Books) and other one-page guides (at jmp.com/learn). 
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Example: Car Physical Data.jmp (Help > Sample Data) 

Summarizing Data Using Tabulate 

Use Tabulate to interactively summarize data and construct tables of descriptive statistics.   

Drag and Drop to Summarize Data 

 From an open JMP® data table select Tables > Tabulate.  

 Drag and drop variables from the column list to the drop zone for 

rows and columns.   

o Country (below, left) is in the rows drop zone – the number of 

observations per country is displayed. 

o Horsepower (middle) is in the columns drop zone as an analysis 

column – the sum for horsepower is displayed for each country. 

 Drag and drop one or more summary statistics from the middle 

panel into the results area. Mean and Std Dev are displayed for 

each country (below, right).  

 

 

 

 

 

 

Tips:  

 Click Undo to reverse the last change, or use Start Over to clear the display. 

 Click and drag variables in the table to rearrange, or right-click on a variable to 
delete or change the format.   

 To change the numeric formats (i.e., decimal places), use Change Format at the 
bottom of the window and select the desired format.   

 To add new summary panels to the table, drag and drop the new variable to the 
bottom or left of the table. Here, Type has been added to the bottom of the 

original table. 

 To add additional row or column variables, drag and 
drop a new variable on either side of the current variable 
in the table. Here, Type has been added next to Country 
and Horsepower has been added next to Weight. 

 To create a data table, click Done, then select Make Into Data 
Table from the top red triangle. 
 

 
 

Note: For more details, see the book Using JMP (under Help > 

Books). 
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Example:	  CrimeData.jmp	  (Help	  >	  Sample	  Data)	  

Mapping	  in	  Graph	  Builder	  

Use	  the	  Graph	  Builder	  to	  create	  interactive	  maps	  of	  U.S.	  states,	  U.S.	  counties,	  and	  worldwide	  countries	  and	  
provinces.	  JMP®	  ships	  with	  these	  shape	  files,	  and	  you	  can	  use	  other	  shape	  files	  (for	  example	  ESRI)	  or	  create	  your	  
own	  custom	  maps.	  See	  the	  page	  Interactive	  Graphing	  with	  Graph	  Builder	  for	  general	  information	  on	  using	  the	  
Graph	  Builder.	  	  

Basic	  Mapping	  

1. From	  an	  open	  data	  table,	  select	  Graph	  >	  Graph	  
Builder.	  	  

2. Drag	  a	  shape	  variable	  from	  the	  Variables	  list	  (for	  
example,	  State)	  to	  the	  map	  shape	  drop	  zone.	  	  

3. Drag	  variables	  into	  other	  drop	  zones	  until	  the	  
desired	  map	  is	  produced.	  	  

4. Use	  the	  Undo	  and	  Start	  Over	  buttons	  to	  try	  
several	  options.	  Click	  Done	  when	  finished.	  

The	  resulting	  display	  depends	  on	  the	  modeling	  type	  of	  the	  variables	  and	  the	  drop	  zone(s)	  used.	  Examples:	  

• Left:	  Region	  (Nominal)	  was	  dropped	  in	  the	  Color	  zone.	  
• Middle:	  Total	  Rate	  (Continuous)	  was	  dropped	  in	  the	  Color	  zone.	  
• Right:	  Total	  Rate	  was	  dropped	  in	  the	  Color	  zone,	  and	  Year	  (Continuous)	  was	  dropped	  in	  the	  Wrap	  zone.	  

	  

	  

	  

	  

	  

Tips:	  	  

• Right-‐click	  on	  the	  legend	  to	  change	  the	  color	  gradient	  or	  transparency. 
• Use	  the	  Data	  Filter	  or	  Local	  Data	  Filter	  to	  dynamically	  select,	  show	  and	  include	  values	  of	  selected	  variables.	  
The	  Data	  Filter,	  under	  the	  Rows	  menu,	  is	  a	  global	  filter	  (selections	  apply	  to	  the	  data	  table	  and	  all	  open	  
windows).	  The	  Local	  Data	  Filter	  applies	  to	  only	  the	  active	  window	  (from	  the	  window	  red	  triangle,	  select	  Script	  >	  
Local	  Data	  Filter).	  See	  “data	  filter”	  in	  JMP	  Help	  for	  additional	  information. 

• If	  your	  data	  set	  contains	  latitudinal	  and	  longitudinal	  data,	  you	  can	  add	  a	  
background	  map	  or	  image.	  Drag	  these	  variables	  to	  the	  X	  and	  Y	  zones,	  right-‐click	  on	  
the	  graph,	  select	  Graph	  >	  Background	  Map	  and	  choose	  the	  desired	  image.	  Double-‐
click	  on	  the	  axes	  to	  change	  the	  scale	  to	  geodesic,	  add	  grid	  lines	  or	  make	  other	  
changes. 

Notes:	  To	  draw	  a	  map,	  shape	  files	  must	  exist	  for	  the	  shape	  variable	  selected.	  For	  more	  information	  on	  mapping,	  
such	  as	  creating	  custom	  maps,	  using	  other	  shape	  files	  or	  working	  with	  background	  maps,	  search	  for	  “creating	  
maps”	  in	  JMP	  Help	  or	  in	  the	  book	  Basic	  Analysis	  and	  Graphing	  (under	  Help	  >	  Books).	  
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